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Overview

Overview

WebSurfer is a client application which allows you to browse multimedia information on the World Wide 
Web (WWW).    WebSurfer displays hypertext documents and supports multimedia such as sound, video, 
and interactive graphics.

About the World Wide Web

The WWW is a set of servers on the Internet that are interconnected through hypertext. Hypertext is a 
method of presenting information where you can expand selected items at any time to provide information
about the item.    These selected items are links which allow you to move from document to document and
server to server.

WebSurfer Features

WebSurfer includes the following features:

· Displays formatted documents (electronic text in a variety of fonts, bold and italic, bulleted lists, 
extended characters sets)

· Browses hypertext-linked documents
· Provides and supports links to FTP, Gopher, and Telnet
· Displays hypermedia documents including interactive graphics, sounds, and movies
· Supports caching of information downloaded to your local drive from the Web
· Tracks the links of your search through the Web, and allows quick backtracking
· Supports external viewers, such as NEWTView and NEWTSound, so you can view text, image, video 

files, and listen to sound files



What is Hypertext?

The Web attempts to organize all the information on the Internet, plus whatever local information you 
want as a set of hypertext documents that use the Hypertext Markup Language (HTML) document format.

Hypertext is a method of presenting information where selected words in the text can be expanded at any 
time to provide other information about the word.    These words are "links" to other documents, which 
may be text, files, graphics, or anything.

HTML enables text formatting, embedded pictures, and hypertext links (anchors) to other documents and 
different locations within documents.    An HTML anchor is a reference to another document or object, or 
to a place within a document.    These references are made through a standard Universal Resource 
Locator (URL), which is a text string consisting of the resource type, the Internet address of the machine, 
and the location of the item on that machine.



About Uniform Resource Locators (URLs)

Uniform Resource Locators (URLs) let you identify where a resource resides anywhere on the Internet by 
pointing at other Web documents on HTTP servers.    If you know the documents URL you can point your 
browser to the document via its URL, though generally you will be navigating via other Web documents 
and will not need to know the URLs. URLs provide information about resource type, location, and path.

Resource types indicate the type of server on which the document resides.    WebSurfer supports the 
following resource types:

http:// is the HTTP Server
ftp:// is the FTP Server
file:// is the local HTML file
telnet:// is the Telnet Server
gopher:// is the Gopher Server

For example the NetManage home page document title is NetManage Home Page and its URL is:

http://www.netmanage.com:80/netmanage/index.html

where:

http is the resource type (HTTP Server)

//www.netmanage.com:80 is the resource location

/netmanage/index.html is the pathname and filename



Using WebSurfer

When you start WebSurfer, the default document window containing the NetManage logo will normally 
appear.    However, in some case this might not happen as Automatic Internet can download pointers to a 
new default. To display the NetManage home page, single-click on the NetManage logo.    The interface 
consists of the document window and the menus and controls surrounding the document.

The Title bar at the top of the window displays the document title.    The Menu bar displays all the menu 
names, with each menu containing drop down lists of commands.    The Toolbar contains buttons that 
serve as shortcuts for WebSurfer menu items.

Below the Toolbar is the Dialog bar which displays the URL address of the current document.    As you 
move the mouse around the document, the Status bar displays the URLs for any anchors or links over 
which the mouse passes.

A document can contain text and pictures, some of which are hypertext links to other multimedia 
documents or objects.    The links are highlighted in blue (default).    You can change the document format,
that is, how it appears on your screen by using the Style Schemes command from the Settings menu.

To gather information about the document you are currently viewing, choose the Properties... command 
from the Retrieve menu.    The Properties dialog box displays information such as:    title, URL, file type, 
and the local file where the document is located.

You can browse through the document and single-click using the left mouse button on the highlighted text
to link to another document.    WebSurfer downloads and displays the new document, including any 
graphics that may be a part of it.    To return to the previous page, choose the Back command from the 
Retrieve menu or the Back toolbar icon.    To return the home page, choose the Home command from the 
Retrieve menu or the Home toolbar icon.

Opening Documents in WebSurfer

There are two methods of opening documents in WebSurfer:    opening a document through its URL 
pathname, or opening an existing local .HTM file from the local file system.

Opening Documents using URL Pathnames

While navigating through a Web document, you can open another document by:

·single-clicking the left mouse button on the highlighted text to link to it.
·entering a documents URL pathname by selecting the Go To URL option under the Retrieve menu.
·entering a documents URL pathname in the Dialog bar and pressing the Return key.

All three methods will retrieve the selected document from the network or local cache (local drive) and 
display it for you.    

Opening Existing Local HTML Files

You can open existing local .HTM files from your local file system. This is useful if you want to edit your 
own .HTM files.    Simply select the Open Local File command from the Retrieve menu and select 
the .HTM file you want to edit.    Then, choose either the Edit HTML command or the View/Play button in 
the Properties option dialog box to edit the document.    Both options will display the .HTM file in the 
default text view if the file is a text file.    It will display the file with the default image viewer if it is an image
file, and will play the file with the default player if it is a sound or movie file.

After you have edited and saved the file, you can view its changes immediately by selecting the Refresh 



From Disk command from the Retrieve menu.



Caching Documents

A major feature that WebSurfer provides is the ability to cache documents or files. Caching keeps a copy 
of documents that you have opened, in your local cache (local drive).    When you re-visit a document, that
is, reopen a previously opened document, you do not have to wait while the information downloads all 
over again from the network.

Default Caching Behavior

When you retrieve a document from the Web, it is downloaded directly from the network and 
automatically placed in your local cache for the current session. If you want to reuse a document you 
have already retrieved during the current session, WebSurfer will retrieve it for you automatically from 
your local cache.

However, when you close the current session, all documents in your local cache will not be saved.    If you
want to re-visit a document you opened during a previous session, then the document is automatically 
retrieved from the network and once again placed in your local cache.

Default caching behavior for documents is specified by using the Preferences command (global behavior 
of all documents) and the Properties command (individual behavior of a specific document).    Note that 
the settings for the caching behavior of a document in the Properties dialog overrides those set in the 
Preferences command.

Overriding Default Caching Behavior

There are several ways you can override the default caching behavior of documents:

Choose the Refresh From Network command under the Retrieve menu to automatically refresh a 
document retrieved from your local cache with its latest version from the network.

To retrieve documents directly from the network and not your local cache, regardless of how many times 
you re-visit the same document, deselect the Reuse Retrieved Documents Within Session checkbox 
located on both the Properties and Preferences dialog boxes.    These are documents you are re-visiting 
in the current session.

To save documents to your local drive between sessions, select the Save Cached Documents Between 
Sessions option, located on both the Properties and Preferences dialog boxes.    Use this option to 
retrieve the same document from your local drive between sessions.



New Configuration

Creates a new configuration file.    When you choose this command, the application provides you with a 
default configuration template (file).

To select a new configuration:

Choose the New Configuration command from the File menu.



Open Configuration...

Opens an existing configuration file.    When you choose Open Configuration..., the application allows you 
to load an existing configuration file.

To open an existing configuration file:

1.      Choose the Open Configuration... command from the File menu.

2.      Select the desired drive, directory and file.

3.      Choose the OK button.



Save Configuration

Saves configuration parameter changes to the current configuration file.

To save configuration parameter changes:

Choose the Save Configuration command from the File menu.



Save Configuration As...

Saves configuration parameter changes to a new configuration file.

To save configuration parameter changes:

1.      Choose the Save Configuration As... command from the File menu.

2.      Select the desired drive, and directory and enter the new file name.

3.      Choose the OK button.



Print...

Allows you to print the HTML document.

To print:

1.      Choose the Print... command from the File menu.

2.      Choose the All option from Print Range, and choose the OK button.



Print Preview

Shows you how the current HTML document will look when you print it.    You can print the current file, 
view the next and previous pages, view the file in one or two page format, and zoom in or out of the file.

To view the contents of the currents window in print preview:

1.      Choose the Print Preview command from the File menu.

2.      Select the desired buttons for printing, viewing in two page format or zooming in and out.

3.      Select the Print Preview command again to return to the previous view of the file.



Print Setup...

Allows you to modify the printer configuration.

To modify the printer setup:

1.      Choose the Print Setup... command from the File menu.

2.      Select either the default printer or a specific printer.

3.      Select additional options according to the specific printer.

4.      Choose the OK button.



Import mosaic.ini File...

Allows you to import user created information from an NCSA Mosaic file.    Information such as user 
created menu items, hotlist items, configuration information, and so on can be imported intact into 
WebSurfer.

To import the contents from a MOSAIC.INI file into WebSurfer:

1.      Choose the Import mosaic.ini File... command from the File menu.

2.      Select the desired drive, and directory and enter the name of MOSAIC.INI file whose contents you 
want to import.

3.      Choose the OK button.



Exit

Exit allows you close the application:

To do this:

Choose the Exit command from the File menu.



Copy

Allows you to copy the contents of the URL edit box at the top of the main WebSurfer window into the 
Clipboard.

For example, you can copy a URL pathname from the URL edit box and paste it into an e-mail message 
or other application via the Clipboard.



Paste

Allows you to paste the contents of the Clipboard into the URL edit box at the top of the main WebSurfer 
window.    

For example, you can paste a URL pathname from a Word file directly into the URL edit box instead of 
manually typing it in.



Go To URL...

Retrieves a document directly from the network or from your local drive (depending how you set 
WebSurfer preferences) and displays it.    After the document is retrieved, it is automatically placed in your
local drive.

To display the selected URL:

1.      Choose the Go To URL... command from the Retrieve menu.    The WebSurfer - Go To Document 
dialog box appears.    Note the server type http://    appears automatically for your convenience.

2.      Enter the URL address of the document you want to display and choose the OK button.

For example, to display the NetManage home page, enter the URL:
http://www.netmanage.com



Refresh From Network

Replaces the selected document (URL) with the latest version from the network and places it in local 
storage.

To refresh a document (URL) with its latest version from the network:

1.      Open the document you want to refresh.

2.      Choose the Refresh From Network command from the Retrieve menu.

The document will be refreshed and placed in local storage.



Open Local File...

Open an existing .HTM file from your local drive.    Use this option if you are creating your own HTML 
document and want to access from your local drive.

To open a file on the local drive:

1.      Choose the Open Local File... command from the Retrieve menu.

2.      Select the desired drive, and directory and file you want to open.

3.      Choose the OK button.



Refresh From Disk

Refreshes the local document from the local file system.    Use this option if you have made changes to a 
local file and want to see those changes.

To refresh a local file:

After modifying a local .HTM file, choose the Refresh From Disk command from the Retrieve menu.

The modified file will be saved on your local drive.



Hotlist...

The Hotlist is a permanent list of documents that you can access with without having to navigate through 
the Web.    You can add documents anytime to the hotlist by using the Add To Hotlist... option.

To display your hotlist:

1.      Choose the Hotlist... command from the Retrieve menu.    The WebSurfer - Hotlist - Favorite Places 
dialog box appears.

2.      Select the title of the document you want to display and choose the Go To button.

3.      You can also display the document's properties by choosing the Properties button or remove the 
document from your hotlist by choosing the Cancel button.



Add To Hotlist

Allows you to automatically add the current document to your Hotlist.

To add the current document to your hotlist:

Choose the Add To Hotlist command from the Retrieve menu.



History...

Lists all the HTML documents you have accessed during the current session.



Back

Allows you to view the previously viewed URL.

To do this:

Choose the Back command from the Retrieve menu, or use the Back toolbar button.



Forward

Allows you to revisit the URL you were viewing before you selected the Back option.

To do this:

Choose the Forward command from the Retrieve menu, or use the Forward toolbar button.



Home

Returns you to the document you entered as the startup document in the Preferences menu.

To return to the document indicated as the startup document in the Preferences menu:

Choose the Home command from the Retrieve menu, or use the Home toolbar button



Properties...

Allows you to change the properties of a selected document only.    You can change its title, file type, add 
a memo about the document, change its file location, and look at the file's text if it is a text file, or see or 
hear it if it is an image or sound file.

Note:    If you want to make global changes to all documents, refer to the Preferences option under the 
Settings menu.

To do this:

1.      Display the URL whose properties you want to change.

2.      Choose the Properties... command from the Retrieve menu.    The URL Properties dialog box 
appears, containing the following fields:

Title Title description of the URL

URL URL pathname

Type File type, such as a Word, 
sound,image or HTML file

Memo Special information about the
URL you may want to include

Local File File location of the URL

Save in Hotlist Save the current document in
your Hotlist

Reuse retrieved
document within
session

Select this if you want to reuse
a document you already
retrieved in the current session.
If you re-visit a document, that
document is retrieved from your
local cache (local drive) and not
the network.

Save cached document
between sessions

Select this if you want a
document you retrieved from
the network to be automatically
saved on your local drive.
When you retrieve this
document during another
session, it is loaded from your
local drive, not the network.

View/Play Shows the file in the default text
view if the file is a text file.
Displays the file with the
default image viewer if an
image file; and plays the file
with the default player if a
sound or movie file.



Edit HTML...

Displays the HTML file in the default text view if the file is a text file.    Displays the file with the default 
image viewer if an image file; and plays the file with the default player if a sound or movie file.

Note:  You can only edit an HTML file you created.    You cannot edit an HTML file that was created by 
another user.

The Edit HTML command provides the same function as the View/Play button on the Properties menu.



Connection Status... 

Displays the current connectivity status.    Status information includes the host name, bytes, rate, time, 
operation, and URL.

You can stop one connection, all connections or clear the screen of inactive connections.



Cancel All

Allows you to cancel anything that is currently being retrieved through the network.



Preferences...

You can set preferences in WebSurfer to indicate the startup document, global document retrieval 
behavior of all documents, the help application filenames, the network software, and proxy server.

To set preferences:

1.      Under Startup Document, select either Browse Files or Load Now.    Browse Files displays the 
WebSurfer Browse Startup Files dialog box where you can choose the selected .HTM file you want to 
appear when you start the application.    Load Now automatically displays the selected .HTM file upon 
starting the application.

2.      Under Default Document Retrieval Behavior, you can select:

Reuse Retrieved Documents Within Session: Select this if you want to reuse a document you 
already retrieved in the current session.    If you re-visit a document, that document is retrieved from 
your local cache (local drive) and not the network.

Save Cached Documents Between Sessions: Select this if you want a document you retrieved 
from the network to be automatically saved on your local drive.    When you retrieve this document 
during another session, it is automatically loaded from your local drive, not the network

Defer Image Retrieval:    When set, causes images not to be rendered as they are retrieved until the 
user gives an explicit render request.    This is useful in preventing display flicker.

3.      To set hypermedia links to Gopher,Telnet and the HTML editor choose the Browse button next to the 
desired helper application.    The Helper Application Filenames contain the filenames you need in 
order to link to Telnet, Gopher and the HTML editor.

4.      WebSurfer uses a different interface to resolve host names.    If you experience problems accessing 
Gopher hosts you may want to try deselecting the Supports Asynchronous Host Name Resolution.    
(The default is selected).

5.      Under Proxy Server, enter the Host Name and the port number.    (the default port number is 80).

6.      Choose the OK button.



Log...

Helps you to diagnose client transmission and WWW server retrieval problems.    

1.      Choose the Log... command from the Settings menu.

2.      Choose the Start button to start logging, or the Stop button to stop logging.

3.      Choose the Save button to save the contents of the log window to the WWW.LOG file.

4.      Choose the Print button to print the contents of the log window.

5.      Choose the Copy button to copy the contents of the log window onto the clipboard.

6.      Choose the Clear button to clear the log window.

7.      Choose the Close button to close the Log... command dialog 



Toolbar ...

Allows you to display or hide the application's toolbar.    The toolbar gives you quick mouse access to 
several of the application's tools.



Smart Buttons

Allows you to display enlarged toolbar icons with descriptions.



Status Bar

Allows you to display or hide the application's status bar.    The status bar is displayed at the bottom of the
window where it shows messages and provides statistics about the current application.



Dialog Bar

Displays the current URL.    You can also go to another URL by entering it in the Dialog bar and pressing 
the Return key.    You can display or hide the Dialog bar by selecting/deselecting the Dialog bar option 
from the Settings menu.



Style Schemes...

Allows you to set style guidelines for the document that is currently displayed    You can select scheme 
elements, font types and styles, point size, foreground/background colors, document color, and margins.

To set the style scheme for a URL file:

1.      Display the URL file whose style scheme you want to set.

2.      Choose the Style Scheme... command from the Settings menu.    The Style Schemes dialog box 
appears.    You can set the following options:

Style Schemes

Preview Element whose attributes you
want to change (You can also
scroll for scheme elements by
name in the Scheme Elements 
field)

Element Attributes
Scheme Elements Element whose style/attributes

you want to change

Indent Determines, in inches, how far
the selected element is
indented within the document

Font Font type of the selected 
element

Font Style Font style of the selected 
element

Size Point size of text of the selected
element

Foreground color Color of the text of the selected 
element

Background color Background color or highlight of
the text

Effects:    Strikeout/Underline Selected element will have a 
line through it or under it 

Document Attributes
Document Color Color of the document 

background

Overall Font Size Globally increase or decreases
by one point size all the
scheme elements

Margins Left and right margins of the 



document during display

Printing Left, right, top, and bottom 
margins of document for 
printing



Troubleshooting

If you experience difficulties using the WebSurfer application, refer to the following item:

o Verify that the installation and setup verification steps have been successfully completed.

NEWTSound and NEWTView are NetManage sound and viewer applications provided for your 
convenience.    However, if you get a message, "Failed to launch viewer for file *.bmp, *.gif etc., check
file associations; check for viewer;"    do the following:

1.      Go to File Manager.
2.      Select Associate option in File Menu.
3.      For the file type bmp, gif, etc., select the viewers using the Browse button. 

Example viewers are:    PAINTBRUSH.EXE, WINGIF.EXE, and so on.

o When you get messages "Unable to resolve the hostname" Check for the following:

Can you ping the hostname?

If you have upgraded to the current version, Make sure that you are not using the old configuration file
and that the corresponding entry for this application is removed from the TCPIP section of the WIN.INI
file

Check whether the correct configuration file is opened in Custom, and all the settings are correct.

o If you are not retrieving any images in the documents, see whether the Defer Image Display option in 
Preferences is enabled.    Disabling it will help you to retrieve the images automatically.

o If you have problems in retrieving the updated documents for example, Stock Quote information and 
reading newspaper articles, make sure that the Reuse documents retrieved documents within session
is disabled.    If it is enabled, then the cached documents are displayed instead of the new updated 
documents from the network.



Diagnose Connection

Choose the Diagnose Connection command to start Ping and verify that the server is available.



Contents

Using Help

To choose a Help topic:

Mouse Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand 
icon.

Keyboard Press Tab to move the highlight to the underlined topic you want to view, and 
then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



About WebSurfer...

Choose the About WebSurfer... command from the Help menu to do the following:

Choose the Copy button to copy the application version information into the Windows Clipboard.    You 
can then paste this information into any application.

Choose the OK button to continue.






